BasicMicroUK - Forums

www.basicmicro.co.uk
It is currently Fri Aug 17, 2018 4:08 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: FTDI driver installation woes
PostPosted: Thu Feb 19, 2015 11:11 pm 
Offline
Citizen

Joined: Fri Mar 01, 2013 7:09 pm
Posts: 19
Hi,

I've installed FTDI drivers for many devices in the past and even for the Nano USB-to Serial programming adapter below and all fine.

http://www.basicmicro.co.uk/Product/B00 ... ASIC-STAMP

However, try as I might I just can't seem to get the driver installed for the FTDI device on my new BasicATOM Lab Board (B0262) below.

http://www.basicmicro.co.uk/Product/B02 ... onics-Demo

I've tried both a Windows 7 and Windows XP machine and the results are identical, it simply won’t recognise the FTDI device as being compatible with the driver.

The device on the BasicATOM Lab Board (B0262) seems identical to the one on the Nano USB-to Serial programming adapter, yet even when I manually point it at these drivers, it doesn't work - I just get 'Communications Port' with a yellow exclamation mark next to it.

Am I missing something obvious?? :?

Many thanks,

Ian

Working drivers for my Nano USB-to Serial programming adapter.

Image

BasicATOM Lab Board (B0262) FTDI serial port.

Image


Top
 Profile  
 
 Post subject: Re: FTDI driver installation woes
PostPosted: Fri Feb 20, 2015 9:49 am 
Offline
Citizen

Joined: Fri Mar 01, 2013 7:09 pm
Posts: 19
Is it possible that the FTDI device on the BasicATOM Lab Board (B0262) is a fake and so has been nobbled by the latest FTDI driver?


Top
 Profile  
 
 Post subject: Re: FTDI driver installation woes
PostPosted: Fri Feb 20, 2015 8:40 pm 
Offline
Site Admin
User avatar

Joined: Fri Apr 12, 2013 8:38 pm
Posts: 87
Location: Nottingham, England, UK
HI Ian

I am not sure what the problem is here as these devices are not normally a problem to install,

I am 100% sure BasicMicro would never have used any none genuine devices and i have had a look at the other Atom Lab boards we have here and they are the genuine FTDI product,

Try installing the drivers included in the link below, uninstall the exsisting driver first and follow the directions in the TXT file and i am sure that will get you up and running fine :-

http://downloads.basicmicro.co.uk/BasicMicroDownloads/BasicMicroCommunicationsPort.zip

Keep us updated on progress,

Many thanks

Dave
BasicMicroUK
http://www.basicmicro.co.uk
01623 720730


Top
 Profile  
 
 Post subject: Re: FTDI driver installation woes
PostPosted: Fri Feb 20, 2015 9:06 pm 
Offline
Citizen

Joined: Fri Mar 01, 2013 7:09 pm
Posts: 19
Hi Dave,

Many thanks for your reply. After looking into the issue I think I've found the cause and you have indeed highlighted it also :)

The FTDI device used seems to have "Basic Micro" burnt into it, so the standard FTDI drivers don't recognize this string. I need to use the driver in the link you've kindly supplied, but sadly this link does not work :(

http://downloads/BasicMicroDownloads/Basic Micro USB Driver/BasicMicroCommunicationsPort.zip

Might you have another link?

Many thanks.

Ian


Top
 Profile  
 
 Post subject: Re: FTDI driver installation woes
PostPosted: Sat Feb 21, 2015 11:54 pm 
Offline
Site Admin
User avatar

Joined: Fri Apr 12, 2013 8:38 pm
Posts: 87
Location: Nottingham, England, UK
Hi Ian

Sorry my mistake, I have updated the link above now, let us know how that works,

Thanks

Dave
BasicMicroUK


Top
 Profile  
 
 Post subject: Re: FTDI driver installation woes
PostPosted: Sun Feb 22, 2015 12:30 am 
Offline
Citizen

Joined: Fri Mar 01, 2013 7:09 pm
Posts: 19
Many thanks indeed, but I'm afraid neither IE or Chrome recognize that as a valid link. :?


Top
 Profile  
 
 Post subject: Re: FTDI driver installation woes
PostPosted: Sun Feb 22, 2015 12:34 am 
Offline
Citizen

Joined: Fri Mar 01, 2013 7:09 pm
Posts: 19
Ahhh, it should be...

http://downloads.basicmicro.co.uk/BasicMicroDownloads/BasicMicroCommunicationsPort.zip


Top
 Profile  
 
 Post subject: Re: FTDI driver installation woes
PostPosted: Sun Feb 22, 2015 7:31 pm 
Offline
Site Admin
User avatar

Joined: Fri Apr 12, 2013 8:38 pm
Posts: 87
Location: Nottingham, England, UK
Thanks for that, corrected the link again,

I am in the middle of moving the files and data from the .com site to the .co.uk site so some things are not linking through correct right now, should have everything sorted next week,

Dave
BasicMicroUK


Top
 Profile  
 
 Post subject: Re: FTDI driver installation woes
PostPosted: Sun Feb 22, 2015 8:33 pm 
Offline
Citizen

Joined: Fri Mar 01, 2013 7:09 pm
Posts: 19
Sounds great - many thanks for your continued support Dave. :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

phpBB SEO