BasicMicroUK - Forums
http://forums.basicmicro.co.uk/

ba 24 will not progam using studio 2.0.0.18
http://forums.basicmicro.co.uk/atom-f484/ba-24-will-not-progam-using-studio-2-0-0-18-t9952.html
Page 1 of 1

Author:  stampee [ Fri Jan 18, 2013 5:25 am ]
Post subject:  ba 24 will not progam using studio 2.0.0.18

I cannot get either of my ba 24 atoms to program using the latest studio. I can however program them using a very old copy of ide 2.2.1
I tried auto detect processor, ba24 and ba 24 rev d to no avail. The studio keeps saying processor not connected. I can however program my ba 40 with studio.
Any advice would be appreciated.
-Stampee

Author:  Brian [ Sat Jan 19, 2013 4:00 pm ]
Post subject:  Re: ba 24 will not progam using studio 2.0.0.18

Hey Stampee,

I just installed 2.0.0.18 and I was able to program my Nano-24 (fresh install of Windows 7 32-Bit). Sounds like you have the wires connected right as you are able to program the Nano-24 but...

Is the processor installed on an bread board? If so you may want to move the Nano-24 over a few pins and re-run the wires. If you are using a Nano Programmer I did discover a bad solder joint on the black connector that I had to re-solder. Don't forget the pull up resistor in the programming circuit.

If the Nano-24 is installed on a Basic Micro board then I'll wait for Ken, Kurt or Nathan to chime in with some ideas.

Good luck-Brian

Author:  Brian [ Sat Jan 19, 2013 5:32 pm ]
Post subject:  Re: ba 24 will not progam using studio 2.0.0.18

I'm bad...sorry...I see that you have a Atom, NOT A NANO.

I still would try moving the processor to a new part of the board "just to see".

Author:  stampee [ Sat Jan 19, 2013 5:40 pm ]
Post subject:  Re: ba 24 will not progam using studio 2.0.0.18

Brian: I tried this to no avail. It programs from the old win95 using ide 2.2.1.
It is on a breadboard yes, but did not help moving it. I also have an atom self made kit I bought years ago and etched my own circuit board for. Darn if I can recall the company.
Anyhow that also will not program from 2.0.0.18 but does program from the old ide 2.2.1
Is there some com port settings or speed settings or something that may have to be changed?
This is not a horrible issue as I DO have a method of programming them, but I am testing code on the atom 24 then transferring it to my atom 40 which is buried inside an R2D2 unit I made, and going out to the garage to test code on the R2 unit is a pain, when it is easier to just test indoors on the atom 24. Also the atom 40 needs the new studio software (for who knows what reason), I have forgotten.
Thank you for the response at any rate.
-Stampee

Author:  Brian [ Sun Jan 20, 2013 1:32 am ]
Post subject:  Re: ba 24 will not progam using studio 2.0.0.18

Gotta love the frustration right :)

I hate to have you try a whole bunch of stuff that won't work BUT may I suggest that you attempt to install an "older version" of BMS (Basic Micro Studio) like version 2.0.0.17 just to see if that does the trick?

I'm not sure how to find the older versions of BMS to download; if you wish e-mail me and I'll send a copy of 2.0.0.17 to you.

-Brian

Author:  KurtEck [ Sun Jan 20, 2013 4:16 pm ]
Post subject:  Re: ba 24 will not progam using studio 2.0.0.18

Are we talking about a real old BA24? One that is several years old? The reason I ask, is I had(have?) an old BA28 that I had this problem with. I believe the newer ones have a different bootloader than the real old ones which don't have this issue.

It has been awhile, but I believe the problem is in the timings. I never had great luck, but at times could get it to work. The thing to try is to play with the Advanced comm settings. Things like reset hold time... You might bring up the OLD ide and see what values it uses and then update the new studio to use these values. Then if it does not work, try slightly modifying these values in both directions and see if you get a set that works.

Good Luck
Kurt

Author:  stampee [ Mon Jan 21, 2013 6:13 am ]
Post subject:  Re: ba 24 will not progam using studio 2.0.0.18

The processor is probably 12-15 years old. I had 2.0.0.15 running when I saw it would not program so upgraded to the latest 2.0.0.18
I will try fiddling with timings etc.
Thanks to everyone for the advice.
-Stampee

Author:  Acidtech [ Wed Jan 23, 2013 8:44 pm ]
Post subject:  Re: ba 24 will not progam using studio 2.0.0.18

Hmm, being that old there may have been some changes to the programming timings to make it incompatible. If you want you can send it in and I'll take a look at it.

Author:  rose61 [ Thu Mar 19, 2015 7:14 am ]
Post subject:  Re: ba 24 will not progam using studio 2.0.0.18

I'm not sure how to find the older versions of BMS to download; if you wish e-mail me and I'll send a copy of 2.0.0.17 to you.






____________________________________________________
:*RosE*:

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/