BasicMicroUK - Forums

www.basicmicro.co.uk
It is currently Wed Oct 17, 2018 8:20 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: BA40 hpwm compiler error
PostPosted: Mon Sep 26, 2011 1:47 am 
Offline
New User

Joined: Sun Sep 25, 2011 7:43 pm
Posts: 2
Hello:

The hpwm command is generating a compiler errors on BA40 with Basic Micro Studio 2.0.0.0.15:

hpwm p9,10000,5000

Error[113] C:\Program FIles\BasicMicro\Basic Micro Studio\system\mbasic14\mbasichard.lib 648 :Symbol not previously defined [DC1B0].

Error[113] C:\Program FIles\BasicMicro\Basic Micro Studio\system\mbasic14\mbasichard.lib 653 :Symbol not previously defined [DC1B1].

The manual says BA40 supports hpwm on p9,p10. What am I missing?

Thanks


Top
 Profile  
 
 Post subject: Re: BA40 hpwm compiler error
PostPosted: Tue Sep 27, 2011 4:55 am 
Offline
Site Admin
User avatar

Joined: Thu Mar 01, 2001 7:00 pm
Posts: 1316
Location: Temecula, CA
Ok. Fixed this for the next release. Until then add this to the top of your program:

DC1B1 con CCP1X
DC1B0 con CCP1Y

When you upgrade to the new release(once I've made it available) you will need to remove these lines because they will cause a duplication error.

_________________
Tech Support
Basic Micro - Robotic Technology Evolved


Top
 Profile  
 
 Post subject: Re: BA40 hpwm compiler error
PostPosted: Wed Sep 28, 2011 1:23 am 
Offline
New User

Joined: Sun Sep 25, 2011 7:43 pm
Posts: 2
Thanks for the quick response. It works.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

phpBB SEO