BasicMicroUK - Forums

www.basicmicro.co.uk
It is currently Wed Apr 25, 2018 3:42 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: cannot get Basic Mirco Studio to connect to BAP 28
PostPosted: Mon Apr 01, 2013 4:41 pm 
Offline
New User

Joined: Mon Apr 01, 2013 4:35 pm
Posts: 2
Hey all. I cannot seem to connect my PC with my BAP 28 in my Bot Board II. I'm using the USB-> serial cable (FTDI USB-to-serial adapter cable FT232R chip) that is sold on the Lynxmotion web site. I have installed the drivers and run the software.

I can get the Basic Micro Studio program to recognize the correct COM port when I plug it in. It seems to know which COM port I have used so something is connecting. I have tried changing from COM1 , COM2, 3, 4, 5, 6, 7, 8, 9 and 10 and the software always knows which one I'm using, but cannot connect to the BAP 28.

When I choose Tools-Preferences- Find Processor it always says "Could not find processor"

I have tried changing Advanced - Reset Hold time from 25 26 27 ... all the way to 100 with no success. Also tried 25 24 ... to 0. No help.

I have a question as well. When I connect the 9v battery the 3 LEDs ABC on the bot board 2 cycle in a pulse and the speaker gives a chirp. As far as I know this is a default program on the BAP 28. Do I need the 9v battery connected while I try to connect to PC??? I have tried both ways and does not seem to make a difference.

Also I have tried this on my Windows 7, 64 bit desktop PC and repeated the whole process on my Windows 7, 32 bit laptop (Using the 32 bit drivers) The same problem with both.

I just can't get Basic Micro Studio to find the BAP 28.

Any ideas????? I am so stuck and just can't think of anything?


Top
 Profile  
 
 Post subject: Re: cannot get Basic Mirco Studio to connect to BAP 28
PostPosted: Mon Apr 01, 2013 10:04 pm 
Offline
New User

Joined: Mon Apr 01, 2013 4:35 pm
Posts: 2
I just did a loop test with my Serial-USB converter and found it worked just fine. Then did a loop test with the serial cable and it failed (both results were repeatable), so it looks like the serial cable I found in the storage basement was just plain broken. I'm gonna hunt for a new cable. I think that was my problem.

Lesson to be learned.
If you are not sure, DO a loop test.

If you are wondering how try this one,

http://www.ni.com/white-paper/3450/en


Top
 Profile  
 
 Post subject: Re: cannot get Basic Mirco Studio to connect to BAP 28
PostPosted: Thu Apr 04, 2013 2:32 am 
Offline
Master

Joined: Sun Jan 03, 2010 4:01 pm
Posts: 134
Location: Eau Claire, WI
Greetings Alegse,

Glad that you resolved your serial problems! I am a networking instructor and I just covered this exact method of testing a serial cable using a loopback plug.

I was just at this website (that you listed) the other day but I somehow missed this article; I'll be sure to share this link with my students so "thank you" for posting :)

Thanks-Brian


Top
 Profile  
 
 Post subject: Re: cannot get Basic Mirco Studio to connect to BAP 28
PostPosted: Tue Apr 09, 2013 7:43 pm 
Offline
Site Admin
User avatar

Joined: Thu Mar 01, 2001 7:00 pm
Posts: 1316
Location: Temecula, CA
I've gone through dozens of cables in my life. They last for a couple years at best. :)

_________________
Tech Support
Basic Micro - Robotic Technology Evolved


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

phpBB SEO