BasicMicroUK - Forums

www.basicmicro.co.uk
It is currently Wed Apr 25, 2018 3:41 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: ARC32 serial communication NOT using Basic Micro Studio
PostPosted: Sat Nov 16, 2013 4:30 am 
Offline
New User

Joined: Sat Nov 16, 2013 4:11 am
Posts: 1
Hey everyone,

So I'm working on some stuff for my ARC32. I've used the Phoenix code on it for quite a while now, and other than burning out servos every now and then, it's great.
Now I've started tinkering with writing my own code, so I can do some serial communication back and forth with the ARC32, but I'm having issues. I'm using the FTDI serial-to-usb converter that's built in to the ARC32, and everything works perfectly in BMS. Despite that, I can't get a peep out of the serial connection in any other terminal programs, or even with simple python scripts. I've tried different baud rates, parity, etc. all with no luck. In short:
Image


Anyhow, I've tried to boil the problem down to its very simplest form, and I'm running this on my ARC32:
Code:
sethserial1 H38400,H8DATABITS,HNOPARITY,H1STOPBITS
START
   hserout 1, ["U3", 10, 13]
   pause 500
   goto START


and this python script (with the pyserial library) on my PC:
Code:
import serial
ser = serial.Serial('/dev/ttyUSB0', 38400, timeout=30)
print ser.name
print ser.isOpen()
print ser.read(4)
ser.close()


At no point have I been able to get serial output from the ARC32 to show up in this python script, or any other terminal (tera term, minicom, etc.) on either of my computers in windows (7 or 8) or linux. I've tried the FTDI signed driver (what a pain to install) and disabling the enforcement of driver signing to use the official (yet unsigned) Basic Micro drivers, all with the same results.

I really feel like I'm overlooking something that's going to seem painfully obvious once it's pointed out, but I'm at a loss after spending most of an afternoon on this. Any ideas? Am I taking crazy pills?


Top
 Profile  
 
 Post subject: Re: ARC32 serial communication NOT using Basic Micro Studio
PostPosted: Fri Nov 22, 2013 7:52 pm 
Offline
Site Admin
User avatar

Joined: Thu Mar 01, 2001 7:00 pm
Posts: 1316
Location: Temecula, CA
The ARC32 use RTS to reset the chip. Most terminal programs will hold this pin in a state which will hold the ARC32 in reset. If you can just turn off RTS(reverse its state). Or if you can't remove the jumper next to the FTDI chip on the ARC32 to disconnect RTS from the AtomPro processor. You will need to pu tit back on when programming.

_________________
Tech Support
Basic Micro - Robotic Technology Evolved


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

phpBB SEO