BasicMicroUK - Forums

www.basicmicro.co.uk
It is currently Tue Jan 23, 2018 11:03 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Cant upload code to DaVinci board
PostPosted: Thu Jul 25, 2013 5:05 pm 
Offline
Citizen

Joined: Wed Jul 24, 2013 10:16 pm
Posts: 6
Hi,

I'm trying to upload a small test programm (blink example) to the DaVinci board but can't get it run. It works perfectly with an Arduino Uno, but not with the DaVinci.

If I choose "Arduino Uno" as a board and press "upload", the RX light flashs three times and the Arduino IDE says:
avrdude: stk500_recv(): programmer is not responding

If I choose "Arduino Leonardo" as a board and press "upload", the RX light flashs two times and the IDE says:
"Upload abgeschlossen" (Upload succesfull).
But there is still the old programm on the board.

I'm using Xubuntu with 64 bit.

Can anybody help me?

Thanks a lot. Cheers!
Dominik


Top
 Profile  
 
 Post subject: Re: Cant upload code to DaVinci board
PostPosted: Thu Jul 25, 2013 5:19 pm 
Offline
Citizen

Joined: Wed Jul 24, 2013 10:16 pm
Posts: 6
I could successfully upload the script after choosing "Arduino Duemilanove w/ ATmega 328". :o
OK, nice. But is this right or would I get problems with this settings, if my program is getting more complex?

Cheers,
Dominik


Top
 Profile  
 
 Post subject: Re: Cant upload code to DaVinci board
PostPosted: Thu Jul 25, 2013 9:06 pm 
Offline
Site Admin
User avatar

Joined: Thu Mar 01, 2001 7:00 pm
Posts: 1316
Location: Temecula, CA
Some of the earliest boards had the Duemilanova bootloader on them. We are now using the UNO bootloader because it is faster downloading(by a small amount). So yes, it is normal for your board. Functionally they are the same. Just slightly faster downloads on the UNO firmware.

_________________
Tech Support
Basic Micro - Robotic Technology Evolved


Top
 Profile  
 
 Post subject: Re: Cant upload code to DaVinci board
PostPosted: Thu Jul 25, 2013 9:57 pm 
Offline
Citizen

Joined: Wed Jul 24, 2013 10:16 pm
Posts: 6
Perfect, thank you!

Now I'm in fight with the rover shield. I can't get the motors of my JohnnyTank to run. Can you please give me a hint or some documentation? I only have the data sheet http://downloads.orionrobotics.com/down ... _R0405.pdf which is not very helpful.

Thanks!
Dominik


Top
 Profile  
 
 Post subject: Re: Cant upload code to DaVinci board
PostPosted: Mon Jul 29, 2013 7:24 pm 
Offline
Site Admin
User avatar

Joined: Thu Mar 01, 2001 7:00 pm
Posts: 1316
Location: Temecula, CA
I replied the rover shield question in a separate post.

_________________
Tech Support
Basic Micro - Robotic Technology Evolved


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

phpBB SEO