BasicMicroUK - Forums

www.basicmicro.co.uk
It is currently Fri Aug 17, 2018 11:23 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 15 posts ] 
Author Message
 Post subject: very very very new :) HELP....
PostPosted: Sat Jan 05, 2013 11:29 am 
Offline
Citizen

Joined: Tue Dec 25, 2012 10:57 am
Posts: 26
hello
Im trying to build a Hexapod using ARC32 and the Phoenix code that I attached here ( I took it from this forms :) ) to try it but im confuse how can i upload it to the ARC32 to run it.

Im really new in robotic and need help


Attachments:
Phoenix%20Beta%202_1%20Phoenix%20Arc32%20Ps2.zip [35.78 KiB]
Downloaded 307 times
Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Sat Jan 05, 2013 3:57 pm 
Offline
Master

Joined: Tue Nov 21, 2006 5:34 pm
Posts: 662
Hi and welcome,

You need to download and install Basic Micros IDE, which you can download from their main download page:
http://www.basicmicro.com/Downloads_ep_43.html

You need to plug the Arc32 into your computer using an FTDI cable and you must have power connected to the Arc32 as well, specifically to the Logic Power. When you plug the ARC32 in for the first time hopefully the appropriate drivers should install. If not, there are drivers up on the same download page I mentioned. If it is a Windows machine running in 64 bit mode you may have to hand do this. There are several threads that mention this...

Once it is installed on your computer, you need to load the project file, in this case it is:
Phoenix_Arc32_PS2.prj

I normally inside the IDE, there are a set of drop down lists. I normally choose these before I try to download. In this Case: BasicATOMPro, BAP Arc32, <the comm port that was created for arc32>

Once this is all done, and the board is connected and powered up, click on the program button near the top of the IDE.

Good Luck
Kurt

Note: The Phoenix code base is talked about more up on the Lynxmotion forums (http://www.lynxmotion.net/index.php)


Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Wed Jan 09, 2013 10:24 am 
Offline
Citizen

Joined: Tue Dec 25, 2012 10:57 am
Posts: 26
Im sorry for the late

I tried to do everything that u said but it gives me errors


Attachments:
Untitled.jpg
Untitled.jpg [ 110.77 KiB | Viewed 5930 times ]
Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Wed Jan 09, 2013 4:10 pm 
Offline
Master

Joined: Tue Nov 21, 2006 5:34 pm
Posts: 662
Builds on my machine? I am using latest version of IDE...

Not sure, double check that you are configured to build for Arc32...


Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Wed Jan 09, 2013 10:46 pm 
Offline
Site Admin
User avatar

Joined: Thu Mar 01, 2001 7:00 pm
Posts: 1316
Location: Temecula, CA
Assuming you have the ARC32 selected, please post the entire error message. Not a screen shot. If you dont have ARC32 selected please recompile with ARC32 selected.

_________________
Tech Support
Basic Micro - Robotic Technology Evolved


Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Fri Feb 15, 2013 7:11 pm 
Offline
Citizen

Joined: Tue Dec 25, 2012 10:57 am
Posts: 26
This is what I got


Attachments:
Ubbb.jpg
Ubbb.jpg [ 251.71 KiB | Viewed 5834 times ]
Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Fri Feb 15, 2013 7:34 pm 
Offline
Site Admin
User avatar

Joined: Thu Mar 01, 2001 7:00 pm
Posts: 1316
Location: Temecula, CA
Let me try this again. Do NOT post a screen shot. This is unhelpful. Copy the error message and past the TEXT into a reply here.

_________________
Tech Support
Basic Micro - Robotic Technology Evolved


Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Fri Feb 15, 2013 8:23 pm 
Offline
Citizen

Joined: Tue Dec 25, 2012 10:57 am
Posts: 26
Do u mean Like this ??
Starting Compiler...
Preparing files...
C:\USERS\B@N911\DESKTOP\PHOENIX%20BETA%202_1%20PHOENIX%20ARC32%20PS2\PHOENIX_CONFIG_3DOFPHOENIX_ARC32.BAS
C:\USERS\B@N911\DESKTOP\PHOENIX%20BETA%202_1%20PHOENIX%20ARC32%20PS2\PHOENIX_CORE.BAS
C:\USERS\B@N911\DESKTOP\PHOENIX%20BETA%202_1%20PHOENIX%20ARC32%20PS2\PHOENIX_CONTROL_PS2.BAS
C:\USERS\B@N911\DESKTOP\PHOENIX%20BETA%202_1%20PHOENIX%20ARC32%20PS2\PHOENIX_DRIVER_ARC32.BAS
C:\USERS\B@N911\DESKTOP\PHOENIX%20BETA%202_1%20PHOENIX%20ARC32%20PS2\PHOENIX_ARC32_EXTRAS.BAS
Compiling...
Error: FILE C:\USERS\B@N911\DESKTOP\PHOENIX%20BETA%202_1%20PHOENIX%20ARC32%20PS2\PHOENIX_CONTROL_PS2.BAS(LINE 179) : [TOKEN )] : Unexpected token type
Errors Detected


Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Sat Feb 16, 2013 3:04 am 
Offline
Site Admin
User avatar

Joined: Thu Mar 01, 2001 7:00 pm
Posts: 1316
Location: Temecula, CA
Yes. Thats what I ment. No double click the error message. It should take you to line 179 of the PHOENIX_CONTROL_PS2.BAS file. There is probably a typo in the file.

_________________
Tech Support
Basic Micro - Robotic Technology Evolved


Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Sun Feb 17, 2013 7:24 am 
Offline
Citizen

Joined: Tue Dec 25, 2012 10:57 am
Posts: 26
good :)
but im sorry i think i will take some of ur time until i finish. if u can for sure.
I dont understand what r u mentioned coz im really new for everything and this project it will be the first thing i do to learn and enter this subject.


Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Fri Mar 01, 2013 12:06 am 
Offline
Site Admin
User avatar

Joined: Thu Mar 01, 2001 7:00 pm
Posts: 1316
Location: Temecula, CA
When you get an error, double click the error message in Studio. This will open the file the error is in and highlight the line the error is on. PLease do that and then show me the line it says has a problem.

_________________
Tech Support
Basic Micro - Robotic Technology Evolved


Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Fri Mar 01, 2013 11:26 am 
Offline
Citizen

Joined: Tue Dec 25, 2012 10:57 am
Posts: 26
this is the line
IF (DualShock(1).bit3 = 0) and LastButton(0).bit3 THEN ;Start Button test
----->IF(HexOn) THEN<----------------
'Turn off


Attachments:
Untitlevgvd.jpg
Untitlevgvd.jpg [ 237.75 KiB | Viewed 5685 times ]
Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Fri Mar 01, 2013 2:59 pm 
Offline
Master

Joined: Tue Nov 21, 2006 5:34 pm
Posts: 662
Have no ideas what is going on. I just re-downloaded the zip file of the code you posted earlier, unzip-ed it to my computer, loaded the project in the IDE and it compiled without error...

Can you try repeating what I just did to make sure your files have not been changed or the like. Probably unzip to different directory. If that works than probably something changed in the sources

Kurt


Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Mon Mar 04, 2013 5:37 pm 
Offline
Citizen

Joined: Tue Dec 25, 2012 10:57 am
Posts: 26
I did and it does not have any error
Thank you so much


Top
 Profile  
 
 Post subject: Re: very very very new :) HELP....
PostPosted: Sun Mar 17, 2013 3:11 pm 
Offline
Master

Joined: Tue Nov 21, 2006 5:34 pm
Posts: 662
I do not know which wires you have? Are you talking about a Lynxmotion PS2? Old one or new one? Do you have one of the wiring cables or a couple of servo extension wires?

Note: my wiring of the PS2 to an Arc32 is from 3 years ago. More details in the thread: http://www.lynxmotion.net/viewtopic.php?f=8&t=6042

If you are using a couple of servo extension wires to the old receiver, I talk about how to connect the wires up to the receiver in the thread: http://www.lynxmotion.net/viewtopic.php ... 4&start=54
If New receiver, with the voltage translation circuit on it, the two cable simple plug into the receiver. In that case I still put the black wire to the first pin(DAT)...

Now on the Arc32, look at the data sheet: http://downloads.basicmicro.com/downloa ... _B0010.pdf
Go to page 9 and you can see information about the Aux2 header. Connect up the PS2 IO pins, to this connector. If you are using the two sets of jumper wires like I mention, connect the first wire (the one were black is DAT) and connect the black to inner set of pins on Aux2, with black on P40. Take 2nd servo wire, remove the Yellow pin from the 2nd connector (I usually use an exacto knife to get under the tab of the pin...), And then plug the yellow wire into P43. Now you need to take the connector with the two remaining wires and plug them into power(VCC) and Ground. You can use the VCC/GND pins on the AUX1 header.

If you are using one of the PS2 connector wires that Lynxmotion sold, there will be a connector with 4 pins on it. There have been several color combinations, so look at their site and plug the 4 pins into P40-P43, plug in the power and GND like I mentioned above

Kurt


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

phpBB SEO